aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rw-r--r--debian/rules15
1 files changed, 15 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100644
index 00000000..deedfacc
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,15 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@
+
+
+override_dh_auto_configure:
+ dh_auto_configure -- -DCMAKE_INSTALL_INCLUDEDIR=include/libqmatrixclient -DBUILD_SHARED_LIBS=1
+
+override_dh_auto_install:
+ dh_auto_install
+# unused example file -- remove to avoid warning from dh_missing
+ rm debian/tmp/usr/bin/qmc-example
+# libQMatrixClient 0.5.3 doesn't change the ABI from libQMatrixClient0.5.1
+ ln -s libQMatrixClient.so.0.5.3.2 debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/libQMatrixClient.so.0.5.1