aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorHubert Chathi <uhoreg@debian.org>2020-04-20 18:39:09 -0400
committerHubert Chathi <uhoreg@debian.org>2020-04-20 18:40:43 -0400
commitf1788ee27f33e9339334e0d79bde9a27d9ce2e44 (patch)
treec809adb841a4e4032b8cd67a35c0c1f1c7ee8acf /debian/rules
parent50106cea246204514447d58f40f7e31e4e0b08fb (diff)
downloadlibquotient-f1788ee27f33e9339334e0d79bde9a27d9ce2e44.tar.gz
libquotient-f1788ee27f33e9339334e0d79bde9a27d9ce2e44.zip
Update packaging for new release.
Diffstat (limited to 'debian/rules')
-rw-r--r--debian/rules15
1 files changed, 15 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100644
index 00000000..deedfacc
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,15 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@
+
+
+override_dh_auto_configure:
+ dh_auto_configure -- -DCMAKE_INSTALL_INCLUDEDIR=include/libqmatrixclient -DBUILD_SHARED_LIBS=1
+
+override_dh_auto_install:
+ dh_auto_install
+# unused example file -- remove to avoid warning from dh_missing
+ rm debian/tmp/usr/bin/qmc-example
+# libQMatrixClient 0.5.3 doesn't change the ABI from libQMatrixClient0.5.1
+ ln -s libQMatrixClient.so.0.5.3.2 debian/tmp/usr/lib/$(DEB_HOST_MULTIARCH)/libQMatrixClient.so.0.5.1