aboutsummaryrefslogtreecommitdiff
path: root/autotests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'autotests/CMakeLists.txt')
-rw-r--r--autotests/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/autotests/CMakeLists.txt b/autotests/CMakeLists.txt
index f35890a5..6afdf8cc 100644
--- a/autotests/CMakeLists.txt
+++ b/autotests/CMakeLists.txt
@@ -12,6 +12,8 @@ function(QUOTIENT_ADD_TEST)
endfunction()
quotient_add_test(NAME callcandidateseventtest)
-quotient_add_test(NAME testolmaccount)
-quotient_add_test(NAME testgroupsession)
-quotient_add_test(NAME testolmsession)
+if(${PROJECT_NAME}_ENABLE_E2EE)
+ quotient_add_test(NAME testolmaccount)
+ quotient_add_test(NAME testgroupsession)
+ quotient_add_test(NAME testolmsession)
+endif()