aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index db5eafe5..1e207478 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -151,6 +151,11 @@ message( STATUS )
# Set up source files
set(lib_SRCS
+ # This .h is special in that it declares a Q_NAMESPACE but has no .cpp
+ # where staticMetaObject for that namespace would be defined; passing it
+ # to add_library (see below) puts it on the automoc radar, producing
+ # a compilation unit with the needed definition.
+ lib/quotient_common.h
lib/networkaccessmanager.cpp
lib/connectiondata.cpp
lib/connection.cpp