aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 15726240..1030e12d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -73,6 +73,7 @@ message(STATUS " Header files will be installed to ${CMAKE_INSTALL_PREFIX}/${${
# Instruct CMake to run moc automatically when needed.
set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
option(BUILD_WITH_QT6 "Build Quotient with Qt 6 (EXPERIMENTAL)" OFF)
@@ -138,6 +139,7 @@ list(APPEND lib_SRCS
lib/eventitem.h lib/eventitem.cpp
lib/accountregistry.h lib/accountregistry.cpp
lib/mxcreply.h lib/mxcreply.cpp
+ lib/keyverificationsession.h lib/keyverificationsession.cpp
lib/events/event.h lib/events/event.cpp
lib/events/eventloader.h
lib/events/roomevent.h lib/events/roomevent.cpp
@@ -171,6 +173,7 @@ list(APPEND lib_SRCS
lib/jobs/syncjob.h lib/jobs/syncjob.cpp
lib/jobs/mediathumbnailjob.h lib/jobs/mediathumbnailjob.cpp
lib/jobs/downloadfilejob.h lib/jobs/downloadfilejob.cpp
+ res.qrc
)
if (${PROJECT_NAME}_ENABLE_E2EE)
list(APPEND lib_SRCS