aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Andreyev <aa13q@ya.ru>2020-02-20 11:57:34 +0300
committerGitHub <noreply@github.com>2020-02-20 11:57:34 +0300
commitd3ca82b9d7477a35e7580f2d6ce579dcbf791d07 (patch)
treee0d53212afd764dacc83dae2e2aee6d5ca3430c8 /tests/CMakeLists.txt
parent43d8bc7212d6fecbed20203a9f5e6e53bfadece3 (diff)
parent17c89693811a4aa27db700d8f9f278393c8e0926 (diff)
downloadlibquotient-d3ca82b9d7477a35e7580f2d6ce579dcbf791d07.tar.gz
libquotient-d3ca82b9d7477a35e7580f2d6ce579dcbf791d07.zip
Merge pull request #379 from quotient-im/aa13q-quotest-readme
[quotest] Update readme, refactor cmake file with variable names
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 490a2506..cb8c99f8 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -48,7 +48,9 @@ endforeach ()
find_package(Qt5 5.9 REQUIRED Network Gui Multimedia Test)
get_filename_component(Qt5_Prefix "${Qt5_DIR}/../../../.." ABSOLUTE)
-find_package(Quotient REQUIRED)
+set(LIBRARY_NAME "Quotient")
+
+find_package(${LIBRARY_NAME} REQUIRED)
get_filename_component(Quotient_Prefix "${Quotient_DIR}/../.." ABSOLUTE)
message( STATUS "${PROJECT_NAME} configuration:" )
@@ -57,12 +59,12 @@ if (CMAKE_BUILD_TYPE)
endif(CMAKE_BUILD_TYPE)
message( STATUS " Compiler: ${CMAKE_CXX_COMPILER_ID} ${CMAKE_CXX_COMPILER_VERSION}" )
message( STATUS " Qt: ${Qt5_VERSION} at ${Qt5_Prefix}" )
-message( STATUS " Quotient: ${Quotient_VERSION} at ${Quotient_Prefix}" )
+message( STATUS " ${LIBRARY_NAME}: ${${LIBRARY_NAME}_VERSION} at ${${LIBRARY_NAME}_Prefix}" )
set(example_SRCS quotest.cpp)
add_executable(${PROJECT_NAME} ${example_SRCS})
-target_link_libraries(${PROJECT_NAME} Qt5::Core Qt5::Test Quotient)
+target_link_libraries(${PROJECT_NAME} Qt5::Core Qt5::Test ${LIBRARY_NAME})
# Installation