aboutsummaryrefslogtreecommitdiff
path: root/quotest/CMakeLists.txt
diff options
context:
space:
mode:
authorHnatiuk Vladyslav <aders1234@gmail.com>2022-01-02 11:27:33 +0100
committerGitHub <noreply@github.com>2022-01-02 11:27:33 +0100
commit8730fb0782860f278760e369b9f42f266f0572b3 (patch)
treeea6b22c418e20a03282483bd599aa79db2e2e6cc /quotest/CMakeLists.txt
parentca6a104941b71e7b6a8bdcb6ebcdfff5ec8e8aca (diff)
parentd516280a2b38ccb060e4f7502b873e19b1559ed1 (diff)
downloadlibquotient-8730fb0782860f278760e369b9f42f266f0572b3.tar.gz
libquotient-8730fb0782860f278760e369b9f42f266f0572b3.zip
Merge branch 'quotient-im:dev' into fix-qt-6
Diffstat (limited to 'quotest/CMakeLists.txt')
-rw-r--r--quotest/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/quotest/CMakeLists.txt b/quotest/CMakeLists.txt
index cb41141d..ec305620 100644
--- a/quotest/CMakeLists.txt
+++ b/quotest/CMakeLists.txt
@@ -8,6 +8,11 @@ find_package(${Qt} COMPONENTS Concurrent)
add_executable(quotest ${quotest_SRCS})
target_link_libraries(quotest PRIVATE ${Qt}::Core ${Qt}::Test ${Qt}::Concurrent ${PROJECT_NAME})
+set_target_properties(quotest PROPERTIES
+ VISIBILITY_INLINES_HIDDEN ON
+ CXX_VISIBILITY_PRESET hidden
+)
+
if (MSVC)
target_compile_options(quotest PUBLIC /EHsc /W4
/wd4100 /wd4127 /wd4242 /wd4244 /wd4245 /wd4267 /wd4365 /wd4456 /wd4459