aboutsummaryrefslogtreecommitdiff
path: root/autotests/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Rusakov <Kitsune-Ral@users.sf.net>2021-01-22 16:38:34 +0100
committerGitHub <noreply@github.com>2021-01-22 16:38:34 +0100
commit0e3973cade9348946a3675a242723711b9b75ad1 (patch)
tree243fc6758f175e0e9d2d2a8581b7072400b63566 /autotests/CMakeLists.txt
parent9fb2970eadf810f7ae38389b333b543c22fb8be7 (diff)
parent390162a0c707c51590acb27df81e98a85d3b6cf7 (diff)
downloadlibquotient-0e3973cade9348946a3675a242723711b9b75ad1.tar.gz
libquotient-0e3973cade9348946a3675a242723711b9b75ad1.zip
Merge pull request #440 from ognarb/callcandidateupdate
Add more properties to CallCandidateEvent
Diffstat (limited to 'autotests/CMakeLists.txt')
-rw-r--r--autotests/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/autotests/CMakeLists.txt b/autotests/CMakeLists.txt
new file mode 100644
index 00000000..07f1f046
--- /dev/null
+++ b/autotests/CMakeLists.txt
@@ -0,0 +1,14 @@
+# SPDX-FileCopyrightText: 2021 Carl Schwan <carlschwan@kde.org>
+#
+# SPDX-License-Identifier: BSD-3-Clause
+
+include(CMakeParseArguments)
+
+function(QUOTIENT_ADD_TEST)
+ cmake_parse_arguments(ARG "" "NAME" "" ${ARGN})
+ add_executable(${ARG_NAME} ${ARG_NAME}.cpp)
+ target_link_libraries(${ARG_NAME} Qt5::Core Qt5::Test Quotient)
+ add_test(NAME ${ARG_NAME} COMMAND ${ARG_NAME})
+endfunction()
+
+quotient_add_test(NAME callcandidateseventtest)