aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKitsune Ral <Kitsune-Ral@users.sf.net>2018-04-03 18:02:35 +0900
committerKitsune Ral <Kitsune-Ral@users.sf.net>2018-04-03 18:02:35 +0900
commiteef87062763a22ff14f829808435d9acc0a411e4 (patch)
tree33e5e1e149874ef786cf81e6867c9cde1bfd3230 /CMakeLists.txt
parent1555dfd596dcdf7e774dd3582802a6f15e6e6cbb (diff)
downloadlibquotient-eef87062763a22ff14f829808435d9acc0a411e4.tar.gz
libquotient-eef87062763a22ff14f829808435d9acc0a411e4.zip
CMakeLists.txt: Specify the API version correctly
It's not version 2, it's still version 0.2.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 956c9a1f..50f04a91 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -91,8 +91,8 @@ aux_source_directory(lib/jobs/generated libqmatrixclient_job_SRCS)
set(example_SRCS examples/qmc-example.cpp)
add_library(QMatrixClient ${libqmatrixclient_SRCS} ${libqmatrixclient_job_SRCS})
-set(API_VERSION 2)
-set_property(TARGET QMatrixClient PROPERTY VERSION "0.2.0")
+set(API_VERSION "0.2")
+set_property(TARGET QMatrixClient PROPERTY VERSION "${API_VERSION}.0")
set_property(TARGET QMatrixClient PROPERTY SOVERSION 0 )
set_property(TARGET QMatrixClient PROPERTY
INTERFACE_QMatrixClient_MAJOR_VERSION ${API_VERSION})