aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKitsune Ral <Kitsune-Ral@users.sf.net>2019-02-09 19:37:12 +0900
committerKitsune Ral <Kitsune-Ral@users.sf.net>2019-02-09 21:16:08 +0900
commitee1d26586572d4d74105a0713d0237dbc2d183f0 (patch)
tree22d81199ca8b77023710a2509a9fbb43d137143a /CMakeLists.txt
parent0ec97b031c4d89acc9ea6e343620f3762f8eb51b (diff)
downloadlibquotient-ee1d26586572d4d74105a0713d0237dbc2d183f0.tar.gz
libquotient-ee1d26586572d4d74105a0713d0237dbc2d183f0.zip
csapi: add RedirectToSSOJob
This is actually a rehash (MSC1721) of redirectToCAS that existed before but was explicitly disabled in the library because of its seeming uselessness in the context of non-web clients. On the second thought, however, `RedirectToSSOJob::makeRequestURL()` can actually be used to open a web browser from a non-web client in order to perform the login procedure.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f0f8ac5a..9729811b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -120,7 +120,6 @@ if (MATRIX_DOC_PATH AND GTAD_PATH)
add_custom_target(update-api
${ABS_GTAD_PATH} --config ${CSAPI_DIR}/gtad.yaml --out ${CSAPI_DIR}
${FULL_CSAPI_SRC_DIR}
- cas_login_redirect.yaml- cas_login_ticket.yaml-
old_sync.yaml- room_initial_sync.yaml- # deprecated
sync.yaml- # we have a better handcrafted implementation
WORKING_DIRECTORY ${PROJECT_SOURCE_DIR}/lib