aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKitsune Ral <Kitsune-Ral@users.sf.net>2020-05-31 13:24:05 +0200
committerKitsune Ral <Kitsune-Ral@users.sf.net>2020-07-18 18:20:27 +0200
commite7bf4f3e4fc059ef9ea0e0b253a1953a91fd77d8 (patch)
treea58ae7a18e85328f855c2342c3bd88b62eaa95e6 /CMakeLists.txt
parent8da4918aa10340ef52177977a8bcad489419f8e2 (diff)
downloadlibquotient-e7bf4f3e4fc059ef9ea0e0b253a1953a91fd77d8.tar.gz
libquotient-e7bf4f3e4fc059ef9ea0e0b253a1953a91fd77d8.zip
ResourceResolver
Introducing the uniform way to resolve Matrix URIs and identifiers to Room/User objects, passing an optional event id (if supplied) to the client-defined handler. Just call ResourceResolver::visitResource() or ResourceResolver::openResource() and you'll have that string parsed and dispatched where you need.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5b6410f1..83075196 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -149,6 +149,7 @@ set(lib_SRCS
lib/room.cpp
lib/user.cpp
lib/avatar.cpp
+ lib/resourceresolver.cpp
lib/syncdata.cpp
lib/settings.cpp
lib/networksettings.cpp