aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Rusakov <Kitsune-Ral@users.sf.net>2021-12-02 15:24:44 +0100
committerAlexey Rusakov <Kitsune-Ral@users.sf.net>2021-12-02 15:24:44 +0100
commitdc08fb9dfd474023084de9ce86f29f177ca52fdc (patch)
tree29cb5ab8a133bc46c4ccbee1cd369cd665525949 /CMakeLists.txt
parentae0ad49f36e8ba5983839581302ed16ddbd75d5f (diff)
downloadlibquotient-dc08fb9dfd474023084de9ce86f29f177ca52fdc.tar.gz
libquotient-dc08fb9dfd474023084de9ce86f29f177ca52fdc.zip
Improve function_traits<>; split out from util.*
Quotient::function_traits<> did not support member functions in a proper way (i.e. the way std::invoke_result<> treats them, with the function's owning class represented as the first parameter). Now that I gained the skill and understanding in function_traits<> somewhat wicked machinery, I could properly support member functions. Overloads and generic lambdas are not supported but maybe we'll get to those one day.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index aa3b9c98..ca92699c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -125,6 +125,8 @@ endif ()
# Set up source files
list(APPEND lib_SRCS
lib/quotient_common.h
+ lib/function_traits.h
+ lib/function_traits.cpp
lib/networkaccessmanager.cpp
lib/connectiondata.cpp
lib/connection.cpp