aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKitsune Ral <Kitsune-Ral@users.sf.net>2017-01-30 17:28:01 +0300
committerKitsune Ral <Kitsune-Ral@users.sf.net>2017-04-13 13:32:36 +0300
commitb5f3a57840986d3ebdc9bb81d73e0c4d6e876071 (patch)
tree89da0af613b8a501e959d0fb61c4883925ade02c /CMakeLists.txt
parent905ebf6c895acfe04ef96f28ac72b303907f70a5 (diff)
downloadlibquotient-b5f3a57840986d3ebdc9bb81d73e0c4d6e876071.tar.gz
libquotient-b5f3a57840986d3ebdc9bb81d73e0c4d6e876071.zip
Use own copy of MIME database on Windows
The one that comes with Qt as a fallback is from 2012 (even from newer Qt versions) and is missing many common content types.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 502fa2b4..16b66c3e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -84,3 +84,8 @@ target_link_libraries(qmatrixclient Qt5::Core Qt5::Network Qt5::Gui)
add_executable(qmc-example ${example_SRCS})
target_link_libraries(qmc-example Qt5::Core qmatrixclient)
+
+if (WIN32)
+ install (FILES mime/packages/freedesktop.org.xml
+ DESTINATION mime/packages)
+endif (WIN32)