aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKitsune Ral <Kitsune-Ral@users.sf.net>2019-08-11 18:13:41 +0900
committerKitsune Ral <Kitsune-Ral@users.sf.net>2019-08-11 18:13:41 +0900
commit9758dfad6d08edf7ae67b38ad59651e33b7e6465 (patch)
tree78b58fd2d995b5bed4eb37e43e8553b667f1defe /CMakeLists.txt
parent372a9ed301e52d6daf7ccdb9a9982a67f46486a1 (diff)
downloadlibquotient-9758dfad6d08edf7ae67b38ad59651e33b7e6465.tar.gz
libquotient-9758dfad6d08edf7ae67b38ad59651e33b7e6465.zip
CMakeLists.txt: tell CMake to not add /W3 flag for MSVC
...because /W4 is explicitly added instead.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dee30bc2..1bc49868 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,7 @@
cmake_minimum_required(VERSION 3.10)
+if (POLICY CMP0092)
+cmake_policy(SET CMP0092 NEW)
+endif()
set(API_VERSION "0.6")
project(Quotient VERSION "${API_VERSION}.0" LANGUAGES CXX)