aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKitsune Ral <Kitsune-Ral@users.sf.net>2019-06-24 07:37:35 +0900
committerKitsune Ral <Kitsune-Ral@users.sf.net>2019-06-24 07:37:35 +0900
commit8d96901ff455e4072dd4b050cf9c17a5780bfacb (patch)
treed4d62b4ae20cb432d1227693a8f60b9dcc48af3e /CMakeLists.txt
parent63ae79c3e2820efc2ba60d33e2caf2d7b9b3c408 (diff)
downloadlibquotient-8d96901ff455e4072dd4b050cf9c17a5780bfacb.tar.gz
libquotient-8d96901ff455e4072dd4b050cf9c17a5780bfacb.zip
CMakeLists.txt: Re-add parts of CSAPI that accidentally went missing
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index da9bb66d..91236ec6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -125,7 +125,8 @@ set(CSAPI_DIR csapi)
set(ASAPI_DEF_DIR application-service/definitions)
set(ISAPI_DEF_DIR identity/definitions)
-foreach (D ${CSAPI_DIR} ${ASAPI_DEF_DIR} ${ISAPI_DEF_DIR})
+foreach (D ${CSAPI_DIR} ${CSAPI_DIR}/definitions
+ ${CSAPI_DIR}/definitions/wellknown ${ASAPI_DEF_DIR} ${ISAPI_DEF_DIR})
aux_source_directory(lib/${D} api_SRCS)
endforeach()