aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKitsune Ral <Kitsune-Ral@users.sf.net>2021-01-15 13:10:41 +0100
committerGitHub <noreply@github.com>2021-01-15 13:10:41 +0100
commit8d9684a4ceec239daf66ff98effe46ab70a3f6a4 (patch)
tree878a6db1895d75c89292b8278731d63fadf248e1 /CMakeLists.txt
parentb0d3ecc774ca4aec24bceb5ec1f1ded844a7213a (diff)
parent544ec34b4563aacac6fd5b2f4aa64813096cd4b8 (diff)
downloadlibquotient-8d9684a4ceec239daf66ff98effe46ab70a3f6a4.tar.gz
libquotient-8d9684a4ceec239daf66ff98effe46ab70a3f6a4.zip
Merge pull request #417 from dfaure/dfaure/stricter-flags
Enable QT_NO_URL_CAST_FROM_STRING and QT_STRICT_ITERATORS.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ce2463bf..29dea14a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -262,7 +262,7 @@ file(GLOB_RECURSE api_SRCS ${add_CONFIGURE_DEPENDS} ${FULL_CSAPI_DIR}/*.cpp)
set(tests_SRCS tests/quotest.cpp)
add_library(${PROJECT_NAME} ${lib_SRCS} ${api_SRCS})
-target_compile_definitions(${PROJECT_NAME} PRIVATE QT_NO_JAVA_STYLE_ITERATORS)
+target_compile_definitions(${PROJECT_NAME} PRIVATE QT_NO_JAVA_STYLE_ITERATORS QT_NO_URL_CAST_FROM_STRING QT_NO_CAST_TO_ASCII)
if (CMAKE_VERSION VERSION_GREATER_EQUAL "3.16.0"
AND NOT CMAKE_CXX_COMPILER_ID STREQUAL GNU) # https://bugzilla.redhat.com/show_bug.cgi?id=1721553
target_precompile_headers(${PROJECT_NAME} PRIVATE lib/converters.h)