aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Fella <fella@posteo.de>2021-08-24 23:59:48 +0200
committerTobias Fella <fella@posteo.de>2021-08-26 18:16:07 +0200
commit8d21c8a6579ad9c63e331ffb42e3ed81b9c73caf (patch)
treef31b2f3e7217302e4dd37e288be6fa6d219401d1 /CMakeLists.txt
parent6953e55361f600a591c08b9cd287a350230b3ef8 (diff)
downloadlibquotient-8d21c8a6579ad9c63e331ffb42e3ed81b9c73caf.tar.gz
libquotient-8d21c8a6579ad9c63e331ffb42e3ed81b9c73caf.zip
Add AccountRegistry
Basic session management class; Created from Quaternion's AccountRegistry and NeoChat's AccountListModel. The connections can be accessed by the user's id, this technically limits it to one connection for each matrix account.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 49105389..3c6e7548 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -140,6 +140,7 @@ list(APPEND lib_SRCS
lib/util.cpp
lib/encryptionmanager.cpp
lib/eventitem.cpp
+ lib/accountregistry.cpp
lib/events/event.cpp
lib/events/roomevent.cpp
lib/events/stateevent.cpp