aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKitsune Ral <Kitsune-Ral@users.sf.net>2016-08-31 17:49:43 +0900
committerKitsune Ral <Kitsune-Ral@users.sf.net>2016-08-31 17:50:56 +0900
commit76241cb772bb53901cdd3308262f76ba718d9a47 (patch)
tree3c4c761384caca211c6647871b7ac62528b5eb50 /CMakeLists.txt
parentc02174bc8f09761c2e4ee3ca4a250ce49025343e (diff)
downloadlibquotient-76241cb772bb53901cdd3308262f76ba718d9a47.tar.gz
libquotient-76241cb772bb53901cdd3308262f76ba718d9a47.zip
Dismiss ConnectionPrivate, long live Connection::Private
Closer investigation found out that there are only two actually used member functions in ConnectionPrivate - provideRoom() and resolveServer(). These two have been transferred to Connection; and data members from ConnectionPrivate found new home in Connection::Private. Factoring out room management and user management from Connection is still a pending task.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1e5dae8f..80ffcfd7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,7 +28,6 @@ message( STATUS )
set(libqmatrixclient_SRCS
connectiondata.cpp
connection.cpp
- connectionprivate.cpp
room.cpp
user.cpp
logmessage.cpp