aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKitsune Ral <Kitsune-Ral@users.sf.net>2017-09-09 21:34:18 +0900
committerKitsune Ral <Kitsune-Ral@users.sf.net>2017-09-09 21:34:18 +0900
commit6300d53663ea118a1f80ceed24648d8553766e17 (patch)
treea2f62cfbb81e3650e5ac8b583622a84cc4d8f93f /CMakeLists.txt
parent24e3d967d7c9029147202e10385b0b8e8881e4d9 (diff)
downloadlibquotient-6300d53663ea118a1f80ceed24648d8553766e17.tar.gz
libquotient-6300d53663ea118a1f80ceed24648d8553766e17.zip
Collect files from jobs/generated into the list of built sources
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5a345e06..9e3abce1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -81,11 +81,13 @@ set(libqmatrixclient_SRCS
jobs/syncjob.cpp
jobs/mediathumbnailjob.cpp
jobs/logoutjob.cpp
- )
+)
+
+aux_source_directory(jobs/generated libqmatrixclient_job_SRCS)
set(example_SRCS examples/qmc-example.cpp)
-add_library(qmatrixclient ${libqmatrixclient_SRCS})
+add_library(qmatrixclient ${libqmatrixclient_SRCS} ${libqmatrixclient_job_SRCS})
set_property(TARGET qmatrixclient PROPERTY VERSION "0.0.0")
set_property(TARGET qmatrixclient PROPERTY SOVERSION 0 )