aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Rusakov <Kitsune-Ral@users.sf.net>2022-06-20 18:21:04 +0200
committerAlexey Rusakov <Kitsune-Ral@users.sf.net>2022-06-21 18:05:02 +0200
commit5d29c23eb82d440163afffe3fd8f7f600149fd64 (patch)
tree36c44a37ae5e78039d60adae56db1cb438bbe836 /CMakeLists.txt
parent3e4aa28596e0020c0b1c49f077e53339762dced3 (diff)
downloadlibquotient-5d29c23eb82d440163afffe3fd8f7f600149fd64.tar.gz
libquotient-5d29c23eb82d440163afffe3fd8f7f600149fd64.zip
CMakeLists: suppress subobject-linkage warnings
GCC (even 12.x) doesn't like when a template parameter is of a pointer/reference type and dumps this warning. See also: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=90670
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 048d3b07..a7a80a73 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -38,7 +38,7 @@ if (MSVC)
/wd4710 /wd4774 /wd4820 /wd4946 /wd5026 /wd5027)
else()
foreach (FLAG Wall Wpedantic Wextra Werror=return-type Wno-unused-parameter
- Wno-gnu-zero-variadic-macro-arguments)
+ Wno-gnu-zero-variadic-macro-arguments Wno-subobject-linkage)
CHECK_CXX_COMPILER_FLAG("-${FLAG}" COMPILER_${FLAG}_SUPPORTED)
if ( COMPILER_${FLAG}_SUPPORTED AND
NOT CMAKE_CXX_FLAGS MATCHES "(^| )-?${FLAG}($| )")