aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKitsune Ral <Kitsune-Ral@users.sf.net>2018-06-03 17:12:35 +0900
committerKitsune Ral <Kitsune-Ral@users.sf.net>2018-06-03 17:12:35 +0900
commit38440a724acf8836e74e5bca29105e493f36eb7c (patch)
tree6c05bb4b413ee5ab72716a77b1128d2f2f8e3b38 /CMakeLists.txt
parent8a8c645f2a2dc91e9d956b7dee8ef5cf741541f4 (diff)
downloadlibquotient-38440a724acf8836e74e5bca29105e493f36eb7c.tar.gz
libquotient-38440a724acf8836e74e5bca29105e493f36eb7c.zip
csapi + converters: Support variant types (using QVariant)
This mandated some rearrangement of toJson() overloads and FromJson<> specializations for QVariant* types - instead of variant_converters.h they are now in converters.cpp.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5f4fe102..aa473adc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -71,6 +71,7 @@ set(libqmatrixclient_SRCS
lib/avatar.cpp
lib/settings.cpp
lib/networksettings.cpp
+ lib/converters.cpp
lib/util.cpp
lib/events/event.cpp
lib/events/eventcontent.cpp