aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFabian Niepelt <fniepelt@takios.de>2016-09-12 19:33:16 +0200
committerFabian Niepelt <fniepelt@takios.de>2016-09-12 19:33:16 +0200
commit2c33811293a5aea38ec552b94f01d51ec16fd442 (patch)
tree461fc32e043418f118a2a9f8ee681b84af1901cb /CMakeLists.txt
parent3860a3ced0ce76a977c4f42ff9a3fa4e98b230e9 (diff)
downloadlibquotient-2c33811293a5aea38ec552b94f01d51ec16fd442.tar.gz
libquotient-2c33811293a5aea38ec552b94f01d51ec16fd442.zip
[FEATURE] Add proper SONAME versioning
This doesn't affect the current build process much but distributions that require libraries to be built as a shared object also often require the use of symbol versioning using the SONAME, e.g openSUSE: https://en.opensuse.org/openSUSE:Shared_library_packaging_policy
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e649f24d..28274789 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -67,6 +67,8 @@ set(libqmatrixclient_SRCS
)
add_library(qmatrixclient ${libqmatrixclient_SRCS})
+set_property(TARGET qmatrixclient PROPERTY VERSION "0.0.0")
+set_property(TARGET qmatrixclient PROPERTY SOVERSION 0 )
if ( CMAKE_VERSION VERSION_LESS "3.1" )
CHECK_CXX_COMPILER_FLAG("-std=c++11" STD_FLAG_SUPPORTED)