aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKitsune Ral <Kitsune-Ral@users.sf.net>2018-01-12 22:07:33 +0900
committerKitsune Ral <Kitsune-Ral@users.sf.net>2018-01-12 23:15:04 +0900
commit24b60a9693d032cc30ce75803730e4727b418087 (patch)
tree8a0ce136bf9fe09de025117aa520b46664e94023 /CMakeLists.txt
parent9e8e958b5d72b9671425b5bcd34fa016874b8677 (diff)
downloadlibquotient-24b60a9693d032cc30ce75803730e4727b418087.tar.gz
libquotient-24b60a9693d032cc30ce75803730e4727b418087.zip
DownloadFileJob
Instead of exposing a QIODevice as GetContentJob does it gets a filename and saves the incoming payload into it.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 533d604f..c0ffc0b0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -74,6 +74,7 @@ set(libqmatrixclient_SRCS
jobs/roommessagesjob.cpp
jobs/syncjob.cpp
jobs/mediathumbnailjob.cpp
+ jobs/downloadfilejob.cpp
)
set(API_DEF_PATH ${MATRIX_DOC_PATH}/api/client-server/)