aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKitsune Ral <Kitsune-Ral@users.sf.net>2019-08-11 17:02:25 +0900
committerKitsune Ral <Kitsune-Ral@users.sf.net>2019-08-11 17:02:25 +0900
commit1803e79038a8f8ab966c40572c039b10bf51072e (patch)
tree2eb7026418aac256a3d47784f491a665bccfd715 /CMakeLists.txt
parente9ae0d5eaac12a276ea352f1e633fb22cdd46828 (diff)
downloadlibquotient-1803e79038a8f8ab966c40572c039b10bf51072e.tar.gz
libquotient-1803e79038a8f8ab966c40572c039b10bf51072e.zip
More MSVC suppresions; switch to C++17 in qmake as well
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f9bdef64..dee30bc2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -38,11 +38,12 @@ set(CMAKE_CXX_STANDARD 17)
if (MSVC)
add_compile_options(/EHsc /W4
- /wd4100 /wd4127 /wd4242 /wd4244 /wd4245 /wd4267 /wd4365 /wd4459 /wd4514
- /wd4571 /wd4619 /wd4623 /wd4625 /wd4626 /wd4710 /wd4774 /wd4820 /wd4946
- /wd5026 /wd5027)
+ /wd4100 /wd4127 /wd4242 /wd4244 /wd4245 /wd4267 /wd4365 /wd4456 /wd4459
+ /wd4464 /wd4505 /wd4514 /wd4571 /wd4619 /wd4623 /wd4625 /wd4626 /wd4706
+ /wd4710 /wd4774 /wd4820 /wd4946 /wd5026 /wd5027)
else()
- foreach (FLAG all "" pedantic extra error=return-type no-unused-parameter no-gnu-zero-variadic-macro-arguments)
+ foreach (FLAG all "" pedantic extra error=return-type no-unused-parameter
+ no-gnu-zero-variadic-macro-arguments)
CHECK_CXX_COMPILER_FLAG("-W${FLAG}" WARN_${FLAG}_SUPPORTED)
if ( WARN_${FLAG}_SUPPORTED AND NOT CMAKE_CXX_FLAGS MATCHES "(^| )-W?${FLAG}($| )")
add_compile_options(-W${FLAG})