aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKitsune Ral <Kitsune-Ral@users.sf.net>2019-08-11 16:05:48 +0900
committerKitsune Ral <Kitsune-Ral@users.sf.net>2019-08-11 16:05:48 +0900
commit0f10255cf20df9415cbafa71b1d131af713f4b82 (patch)
treeb222e44187f869dd5cb7c26dcfd76207380ddc25 /CMakeLists.txt
parent35d9c4dd6743d706ed9382c021923ef790e7c446 (diff)
downloadlibquotient-0f10255cf20df9415cbafa71b1d131af713f4b82.tar.gz
libquotient-0f10255cf20df9415cbafa71b1d131af713f4b82.zip
CMakeLists.txt: suppress some MSVC warnings
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d90b2d88..da38bc78 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,7 +37,9 @@ endif()
set(CMAKE_CXX_STANDARD 17)
if (MSVC)
- add_compile_options(/EHsc /W4)
+ add_compile_options(/EHsc /W4
+ /Wd4100 /Wd4242 /Wd4245 /Wd4267 /Wd4365 /Wd4571 /Wd4625 /Wd4626 /Wd4820
+ /Wd5026 /Wd5027)
else()
foreach (FLAG all "" pedantic extra error=return-type no-unused-parameter no-gnu-zero-variadic-macro-arguments)
CHECK_CXX_COMPILER_FLAG("-W${FLAG}" WARN_${FLAG}_SUPPORTED)