aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKitsune Ral <Kitsune-Ral@users.sf.net>2019-08-11 13:17:31 +0900
committerKitsune Ral <Kitsune-Ral@users.sf.net>2019-08-11 13:17:31 +0900
commit0ecc5d4992ad2086ee9e399a23f233b653b74ee3 (patch)
treec135e627ed7382922d5b9193e618f398ffd838f4 /CMakeLists.txt
parent64d096d3f8cdf93216ab138ea0378ae60a19b7d2 (diff)
downloadlibquotient-0ecc5d4992ad2086ee9e399a23f233b653b74ee3.tar.gz
libquotient-0ecc5d4992ad2086ee9e399a23f233b653b74ee3.zip
Officially bump requirements: CMake 3.10, C++17, Qt 5.9
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 4 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e0ff6f19..d0ce98a6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 3.5)
+cmake_minimum_required(VERSION 3.10)
set(API_VERSION "0.6")
project(Quotient VERSION "${API_VERSION}.0" LANGUAGES CXX)
@@ -34,7 +34,7 @@ if (NOT CMAKE_INSTALL_INCLUDEDIR)
set(CMAKE_INSTALL_INCLUDEDIR "include")
endif()
-set(CMAKE_CXX_STANDARD 14)
+set(CMAKE_CXX_STANDARD 17)
foreach (FLAG all "" pedantic extra error=return-type no-unused-parameter no-gnu-zero-variadic-macro-arguments)
CHECK_CXX_COMPILER_FLAG("-W${FLAG}" WARN_${FLAG}_SUPPORTED)
@@ -43,9 +43,7 @@ foreach (FLAG all "" pedantic extra error=return-type no-unused-parameter no-gnu
endif ()
endforeach ()
-# Qt 5.6+ is the formal requirement but for the sake of supporting UBPorts
-# upstream Qt 5.4 is required.
-find_package(Qt5 5.4.1 REQUIRED Network Gui Multimedia)
+find_package(Qt5 5.9 REQUIRED Network Gui Multimedia)
get_filename_component(Qt5_Prefix "${Qt5_DIR}/../../../.." ABSOLUTE)
if ((NOT DEFINED USE_INTREE_LIBQOLM OR USE_INTREE_LIBQOLM)
@@ -265,8 +263,7 @@ install(FILES cmake/QuotientConfig.cmake
"${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}/QuotientConfigVersion.cmake"
DESTINATION ${ConfigFilesLocation}
)
-# Only available from CMake 3.7; reserved for future use
-#install(EXPORT_ANDROID_MK QuotientTargets DESTINATION share/ndk-modules)
+install(EXPORT_ANDROID_MK QuotientTargets DESTINATION share/ndk-modules)
if (WIN32)
install(FILES mime/packages/freedesktop.org.xml DESTINATION mime/packages)