aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Rusakov <Kitsune-Ral@users.sf.net>2021-12-03 21:22:46 +0100
committerAlexey Rusakov <Kitsune-Ral@users.sf.net>2021-12-03 21:35:08 +0100
commit0d212bdb7849d12582d906a03935cb6f51767e3b (patch)
treefc4d4213932a2175c8fd4935af7e5c4ffb47380c /CMakeLists.txt
parentdc458f3952b0005a0feb63fbebed11ae9ad5a062 (diff)
downloadlibquotient-0d212bdb7849d12582d906a03935cb6f51767e3b.tar.gz
libquotient-0d212bdb7849d12582d906a03935cb6f51767e3b.zip
Add a couple of bare .h files to CMakeLists.txt
These were missing from the commit introducing .h files to sources, highlighting the reason why .h files should be there...
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8d9be635..2762df6a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -149,13 +149,16 @@ list(APPEND lib_SRCS
lib/events/event.h lib/events/event.cpp
lib/events/roomevent.h lib/events/roomevent.cpp
lib/events/stateevent.h lib/events/stateevent.cpp
+ lib/events/simplestateevents.h
lib/events/eventcontent.h lib/events/eventcontent.cpp
lib/events/roomcreateevent.h lib/events/roomcreateevent.cpp
lib/events/roomtombstoneevent.h lib/events/roomtombstoneevent.cpp
lib/events/roommessageevent.h lib/events/roommessageevent.cpp
lib/events/roommemberevent.h lib/events/roommemberevent.cpp
+ lib/events/roomavatarevent.h
lib/events/roompowerlevelsevent.h lib/events/roompowerlevelsevent.cpp
lib/events/typingevent.h lib/events/typingevent.cpp
+ lib/events/accountdataevents.h
lib/events/receiptevent.h lib/events/receiptevent.cpp
lib/events/reactionevent.h lib/events/reactionevent.cpp
lib/events/callanswerevent.h lib/events/callanswerevent.cpp