aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHubert Chathi <uhoreg@debian.org>2020-04-20 18:01:38 -0400
committerHubert Chathi <uhoreg@debian.org>2020-04-20 18:01:38 -0400
commit035d428becd62869b88793bb48d59410056b1f31 (patch)
tree0cd837955fa1037c74ee524a089ff1b788b75861 /CMakeLists.txt
parent688dc682e0c6ae12dc87d781ffe53c974dad60df (diff)
parentd8e1f4ee70902e2b9e5e9c699423d7f3fafe6238 (diff)
downloadlibquotient-035d428becd62869b88793bb48d59410056b1f31.tar.gz
libquotient-035d428becd62869b88793bb48d59410056b1f31.zip
Update upstream source from tag 'upstream/0.5.3.2'
Update to upstream version '0.5.3.2' with Debian dir 49a325a077f4a2ebcd5b73adf3782a6fb5ecb3fe
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b2536f1b..e503bc5f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,7 @@
cmake_minimum_required(VERSION 3.1)
-set(API_VERSION "0.5.1") # Normally it should just include major.minor
-project(qmatrixclient VERSION "0.5.2" LANGUAGES CXX)
+set(API_VERSION "0.5.3") # Normally it should just include major.minor
+project(qmatrixclient VERSION "0.5.3.2" LANGUAGES CXX)
option(QMATRIXCLIENT_INSTALL_EXAMPLE "install qmc-example application" ON)
@@ -78,6 +78,7 @@ set(libqmatrixclient_SRCS
lib/networkaccessmanager.cpp
lib/connectiondata.cpp
lib/connection.cpp
+ lib/ssosession.cpp
lib/logging.cpp
lib/room.cpp
lib/user.cpp
@@ -98,6 +99,7 @@ set(libqmatrixclient_SRCS
lib/events/roommemberevent.cpp
lib/events/typingevent.cpp
lib/events/receiptevent.cpp
+ lib/events/reactionevent.cpp
lib/events/callanswerevent.cpp
lib/events/callcandidatesevent.cpp
lib/events/callhangupevent.cpp