aboutsummaryrefslogtreecommitdiff
path: root/quotest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'quotest/CMakeLists.txt')
-rw-r--r--quotest/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/quotest/CMakeLists.txt b/quotest/CMakeLists.txt
index d17e8620..29c53fae 100644
--- a/quotest/CMakeLists.txt
+++ b/quotest/CMakeLists.txt
@@ -6,3 +6,11 @@ set(quotest_SRCS quotest.cpp)
add_executable(quotest ${quotest_SRCS})
target_link_libraries(quotest PRIVATE Qt5::Core Qt5::Test ${PROJECT_NAME})
+
+option(${PROJECT_NAME}_INSTALL_TESTS "install quotest (former qmc-example) application" ON)
+add_feature_info(InstallQuotest ${PROJECT_NAME}_INSTALL_TESTS
+ "the library functional test suite")
+
+if (${PROJECT_NAME}_INSTALL_TESTS)
+ install(TARGETS quotest RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+endif ()