aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index deb50aea..49105389 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -122,11 +122,7 @@ endif ()
# Set up source files
list(APPEND lib_SRCS
- # This .h is special in that it declares a Q_NAMESPACE but has no .cpp
- # where staticMetaObject for that namespace would be defined; passing it
- # to add_library (see below) puts it on the automoc radar, producing
- # a compilation unit with the needed definition.
- lib/quotient_common.h
+ lib/quotient_common.cpp
lib/networkaccessmanager.cpp
lib/connectiondata.cpp
lib/connection.cpp