aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 24cdd58d..502fa2b4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -74,8 +74,13 @@ set(libqmatrixclient_SRCS
jobs/logoutjob.cpp
)
+set(example_SRCS examples/qmc-example.cpp)
+
add_library(qmatrixclient ${libqmatrixclient_SRCS})
set_property(TARGET qmatrixclient PROPERTY VERSION "0.0.0")
set_property(TARGET qmatrixclient PROPERTY SOVERSION 0 )
target_link_libraries(qmatrixclient Qt5::Core Qt5::Network Qt5::Gui)
+
+add_executable(qmc-example ${example_SRCS})
+target_link_libraries(qmc-example Qt5::Core qmatrixclient)