aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 91ee8217..b021411c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -101,7 +101,7 @@ find_package(${Qt}Keychain REQUIRED)
if (${PROJECT_NAME}_ENABLE_E2EE)
find_package(${Qt} ${QtMinVersion} REQUIRED Sql)
- find_package(Olm 3.1.3 REQUIRED)
+ find_package(Olm 3.2.5 REQUIRED)
set_package_properties(Olm PROPERTIES
DESCRIPTION "Implementation of the Olm and Megolm cryptographic ratchets"
URL "https://gitlab.matrix.org/matrix-org/olm"
@@ -150,6 +150,7 @@ list(APPEND lib_SRCS
lib/eventitem.h lib/eventitem.cpp
lib/accountregistry.h lib/accountregistry.cpp
lib/mxcreply.h lib/mxcreply.cpp
+ lib/e2ee/e2ee.h # because it's used by generated API
lib/events/event.h lib/events/event.cpp
lib/events/eventloader.h
lib/events/roomevent.h lib/events/roomevent.cpp
@@ -193,7 +194,6 @@ if (${PROJECT_NAME}_ENABLE_E2EE)
lib/e2ee/qolmoutboundsession.h lib/e2ee/qolmoutboundsession.cpp
lib/e2ee/qolmutils.h lib/e2ee/qolmutils.cpp
lib/e2ee/qolmutility.h lib/e2ee/qolmutility.cpp
- lib/e2ee/qolmerrors.h lib/e2ee/qolmerrors.cpp
lib/e2ee/qolmsession.h lib/e2ee/qolmsession.cpp
lib/e2ee/qolmmessage.h lib/e2ee/qolmmessage.cpp
lib/events/keyverificationevent.h