aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 2 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dfb60ea6..d930bbf2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -72,13 +72,9 @@ message(STATUS " Header files will be installed to ${CMAKE_INSTALL_PREFIX}/${${
# Instruct CMake to run moc automatically when needed.
set(CMAKE_AUTOMOC ON)
-option(BUILD_WITH_QT6 "Build Quotient with Qt 6" OFF)
+option(BUILD_WITH_QT6 "Build Quotient with Qt 6 (EXPERIMENTAL)" OFF)
-if (NOT BUILD_WITH_QT6)
- # Use Qt5 by default
- find_package(Qt5 5.12 QUIET COMPONENTS Core)
-endif()
-if (NOT Qt5Core_FOUND OR BUILD_WITH_Qt6)
+if (BUILD_WITH_QT6)
find_package(Qt6 6.2 REQUIRED Core Network Gui Test) # TODO: Multimedia
set(Qt Qt6)
qt6_wrap_cpp(lib_SRCS lib/quotient_common.h)